ビルドエラー」カテゴリーアーカイブ

WebKitGTK

BLFSにてGnome環境を構築しようと思ったら、途中でWebKitGTK+なるパッケージを導入する必要がある。BLFSブック現時点にて、このパッケージはWebKitGTK+-1.10.2 さて最新のLFS-SVN-20 … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

nss-3.14

nss-3.14をビルドしようとして、エラーになった。 ふと思いついて、export MAKEFLAGS=’-j 2′ を常々定義し、種々のパッケージをコンパイルしてきているのが悪さをしているよう … 続きを読む

カテゴリー: LFS, ビルドエラー, ビルド手順 | コメントする

Net-tools

Net-toolsはコマンド ifconfig を提供するパッケージであり、IPアドレス確認時に何かと利用している。 LFS SVN-20121002 より Linux カーネルが 3.6 となり、linux/if_st … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

Subversion-1.7.6

2012/08/15 にリリースされた Subversion-1.7.6 を本日ビルド。 (LFS SVN-20120824、VMware Workstation 9 上) ただしエラー発生。 エラーを取り損ねたが、だい … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

Net-tools

LFSブック SVN-20120816 にて Net-tools をビルドしようとしてエラー: cc -O2 -g -Wall -fno-strict-aliasing -I.. -I../include -D_GNU_ … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

Heimdal から MIT Kerberos 5 へ

BLFSブックにて最近、Heimdalが削除された。これまでこれを採用してきたのであるが、代わりに MIT Kerberos 5 を利用していくことになる。そこで krb5-1.10.1 の初めてのビルド。LFS 最新の … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

libprelude

libprelude-1.0.0 のビルドを再度行ってみた。 前の投稿にて、gnutls-3.0.5 以降、ビルド出来なくなっていたもの。 今 gnutls の最新は 3.0.9 エラーは gnutls/extra.h … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

LFS svn-20120126

LFS svn-20120126 ビルド完。 少々ハマったのでメモ。 ビルド後に起動すると「unknown filesystem type: ‘devtmpfs’」みたいなエラーが出て、起動できなかった。エラーは正確に書 … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

w3m-0.5.3

久々に w3m をビルドする必要が出てきたので LFS-SVN20111223 (Linux-3.0.5, glibc-2.14, etc.) をベースに、BLFSブックにて示される w3m-0.5.2 をビルドしようと … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする

libprelude

libprelude-1.0.0 がビルドできなくなった。 gnutls-3.0.5 にしたのが原因か。 gnutls-3.0.4 までは gnutls/extra.h が存在していたのに、 gnutls-3.0.5 か … 続きを読む

カテゴリー: LFS, ビルドエラー | コメントする