wget-1.13

Wget が 1.13 にアップグレードしたので、LFS にてビルドしようとしたら、gnutls がない、として怒られた。かつては OpenSSL か GnuTLS のいずれかがあれば良かったように記憶。仕方ないので gnutls を入れることに。

最新を確認してみると、gnutls-3.0.0 が出ていた。これまでは gnutls-2.16.x あたりをビルドしてきていた。この際だから gnutls もアップグレードしようと思った・・・そしたら今度は nettle で怒られる。

nettle は gnutls-2.16.? のいずれかの版から必須パッケージとなっていたため、既に nettle-2.1 をビルドしてきた経緯があったのであるが、gnutls-3.0.0 は nettle-2.2 以上でないといけないらしい。さらに p11-kit なるものも新たに必要だとか。

それらをすべてビルドした上で、ようやく wget-1.13 ビルド完了。

カテゴリー: LFS パーマリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です